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My AR Studio 

- My AR Studio: what it is

- My AR Studio: how it works

- Exercise

- Preparing a model in KeyShot

- Real-time rendering and exporting in GLB

Course program
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My AR Studio is a cloud system that allows you to upload 
and distribute your products on the web and in AR.

What it is
www.myarstudio.cloud 
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click to see the video

https://docs.google.com/file/d/1FAa9hZgiYnOBi8kCpn0rCJeuBGp5tAWk/preview
https://www.youtube.com/watch?v=hfsruS0u44k


youtube.com/@myarstudio instagram.com/my.ar.studio myarstudio.cloud/learn

info@myarstudio.cloudit.linkedin.com/showcase/myarstudio

Links
Access our contents

https://www.youtube.com/@myarstudio
http://instagram.com/my.ar.studio
https://www.myarstudio.cloud/learn/
mailto:myarstudio@puntoquindici.it
http://it.linkedin.com/showcase/myarstudio
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How it works
Drag the model of your product in GLB format into the My AR Studio editor.

Set the colors and lighting that best enhance it.

Publish it in several independent configurations or grouped in a single 
product selector.
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Distribution
The Universal Viewer of 
My AR Studio is the tool 
to distribute your products 
on any type of device.

Through the automatic 
generation of links, QR 
Codes and HTML, you can 
cover both desktop and 
mobile browsers, as well 
as the native Augmented 
Reality view of Apple iOS 
and Android.

No app needed.
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myarstudio.cloud/examples

Use Cases
Quality and versatility exemplified.

Click on the images to open the examples

https://www.myarstudio.cloud/examples/
https://viewer.myarstudio.cloud/viewer_master/index.html?p=b8402fe3-866e-5cd3-8211-c1fb782b4e5c&c=ea5db9f6-7ec7-53b3-98a7-6e275d9ca6b6&b=d9525a15-3673-4474-9841-b2b3dcb7a78a
https://viewer.myarstudio.cloud/viewer_master/index.html?p=61bc508d-fca6-5de8-af87-4ac04a217e8e&c=ecbe813f-1ef0-51ad-b40b-b398eb4bb26c&b=d9525a15-3673-4474-9841-b2b3dcb7a78a
https://viewer.myarstudio.cloud/viewer_master/index.html?p=f869f84a-b610-546e-b962-d03c1560691f&c=6e5dae4d-2b46-5797-b71f-71d68f436a23&b=d9525a15-3673-4474-9841-b2b3dcb7a78a
https://cloud-myarstudio-utils.s3.eu-central-1.amazonaws.com/viewer_master/index.html?p=6313a734-8121-564f-85c5-127c17945ca7&c=6ba26219-e26e-5204-b36d-d034887e1995&b=d9525a15-3673-4474-9841-b2b3dcb7a78a
https://viewer.myarstudio.cloud/viewer_master/index.html?p=b515d3fe-ecc8-516b-b275-332b90242514&c=ae96f37b-4460-5947-92d8-4d6dc6fd7488&b=d9525a15-3673-4474-9841-b2b3dcb7a78a
https://viewer.myarstudio.cloud/viewer_master/index.html?p=1b519277-1515-5206-ac27-584872a25259&c=ba6205ae-0241-5b5a-8926-3993ba75b468&b=d9525a15-3673-4474-9841-b2b3dcb7a78a
https://viewer.myarstudio.cloud/viewer_master/index.html?p=b8402fe3-866e-5cd3-8211-c1fb782b4e5c&c=ea5db9f6-7ec7-53b3-98a7-6e275d9ca6b6&b=d9525a15-3673-4474-9841-b2b3dcb7a78a
https://viewer.myarstudio.cloud/viewer_master/index.html?p=61bc508d-fca6-5de8-af87-4ac04a217e8e&c=ecbe813f-1ef0-51ad-b40b-b398eb4bb26c&b=d9525a15-3673-4474-9841-b2b3dcb7a78a
https://cloud-myarstudio-utils.s3.eu-central-1.amazonaws.com/viewer_master/index.html?p=6313a734-8121-564f-85c5-127c17945ca7&c=6ba26219-e26e-5204-b36d-d034887e1995&b=d9525a15-3673-4474-9841-b2b3dcb7a78a
https://viewer.myarstudio.cloud/viewer_master/index.html?p=f869f84a-b610-546e-b962-d03c1560691f&c=6e5dae4d-2b46-5797-b71f-71d68f436a23&b=d9525a15-3673-4474-9841-b2b3dcb7a78a
https://viewer.myarstudio.cloud/viewer_master/index.html?p=b515d3fe-ecc8-516b-b275-332b90242514&c=ae96f37b-4460-5947-92d8-4d6dc6fd7488&b=d9525a15-3673-4474-9841-b2b3dcb7a78a
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myarstudio.cloud/learn

youtube.com/@myarstudio

Extensive documentation with video tutorials:

- My AR Studio
- KeyShot
- Blender
- Substance Painter

Documentation

https://www.myarstudio.cloud/learn/
https://www.youtube.com/@myarstudio
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Test your smartphone

Recommended requirements
To work in Augmented Reality with My AR Studio we advice:

Creation

- Chrome web browser

Web viewer

- Any web browser

Augmented Reality

- Recent or enabled smartphones (see this link)
- Chrome on Android
- Safari on iOS

https://www.myarstudio.cloud/learn/documentation/distribute/augmented-reality/


My AR Studio
How it works

11
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My AR Studio

Projects Page

Project list, account management and useful 
links.

Configurations Page

Management of the configurations that belong 
to a project.

Editor Page

Set up and modify a single configuration
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Projects Page
Left column

- Project List
- User Profile
- Logout
- Contextual guide
- Documentation
- Bug reports
- Chat

Plan details panel

Main area

- Add project button
- Search projects by name
- Project list
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Editor
After clicking the + button next to the Projects header, the editor 
screen for a new project opens.

- Center 3D area 
- Top Project header
- Right 5 tabs with project properties

Drag a GLB file into the window to have it loaded into the editor.

Click in the header to give the project a meaningful name.
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Editor: Export Tab 
In the first tab you can generate the poster, the image used as 
a preview of your project:

- Activate the poster icon
- Orient the template as you prefer
- Click the generate poster button
- Deactivate the poster icon

Set the export options for the project. These are the same 
options available on the configurations page.

Click the Save and Publish button to publish the project in My AR 
Studio.
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Editor: Lightning Tab
Here you can set how the model will be displayed in the 
Universal Viewer. Specifying:

- The HDR to be used for the lighting and its exposure
- The background
- The intensity and blurring of the shadows
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The final appearance of the model will depend on the viewing 
mode used.

In the Universal Viewer the lighting settings specified in the 
editor will be used.

In the AR Viewer the user's smartphone will sample the ambient 
light. It will use this instead of the lighting settings to better fit the 
rendering into the image captured by the camera.

Editor: Lightning Tab
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Editor: Materials Tab 
In the materials tab you can change how the model will look in 
both the Universal Viewer and AR.

It is possible to affect: color, roughness, metallicity, emission and 
transparency.

The actual editing possibilities depend on the export 
specifications that were used in generating the GLB file.
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Editor: Hotspot Tab
Here you can add hotspots with interactive labels that will only 
be visible in the universal viewer

Optionally, the user can be given the choice of whether or not to 
display the hotspots.
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Editor: Dimensions Tab 
In the dimensions tab you can check the actual size of the 
model and scale it to your liking.
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Configurations Page
By publishing a project from the editor, or by clicking on the project 
icon from the project list page, you enter the configuration editor. 

A configuration is a particular setting of your product that can vary 
by: materials, lighting, model, etc.

Next to the thumbnail of each configuration are 4 buttons:

- edit configuration
- duplicate the configuration
- rename the configuration
- delete the configuration

At the bottom right are the exports of the selected configuration: 

- Universal Viewer link and embed code
- QRcode download
- Poster Image link and download
- USDZ model link and download
- GLB model link and download



22

Open the Preview & Options panel to enable the Universal 
Viewer features for the selected configuration.

- Model Visibility in AR
- Automatic start of 3D web visualization
- Visibility of hotspots
- Visibility of dimensions
- Model placement in AR view

Configurations Page
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The Product Selector tab allows several configurations to be 
included in a single view in the Universal Viewer.

The user could then choose the version of the product they 
prefer via a convenient drop-down menu.

The Product Selector has its own specific preview & options 
settings, distinct from those of individual configurations.

At the bottom right will be the Product Selector exports, also 
distinct from those of the individual configurations.

- Universal Viewer link and embed code
- QRcode download

Configurations Page
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Delete a configuration
Clicking on the delete configuration button or the delete project 
button, depending on which page we are on, will open a 
confirmation dialog.

My AR Studio does not immediately perform the deletion because 
the links, embed code and QR code associated with the 
configuration will stop working. So to users who click on an already 
published link will be returned a "project not found" page.

Deleted links are not recoverable. If we load the same object into a 
new project or a new configuration, new links will be generated that 
are different from the previous ones.

Instead, remember that configurations are continuously updatable. 
For example, if a new version of our product has come out, we can 
change the already published configuration by uploading the new 
model. The old links will continue to work, however, showing the 
updated version.



Exercise
Load and publish a model
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Model preparation
Optimization and troubleshooting with KeyShot
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Overview
The purpose of preparing the model for export is to find the best possible 
compromise between weight and quality. Ensuring less loading time for the 
user and a performant AR view on every enabled smartphone model.

Export checklist

- Reducing the number of objects
- Reduction in the number of polygons
- Orientation of surface normals
- Separation of surfaces by material
- Compatibility of materials
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15 objects 7425 objects

Number of objects
Real-time engines cannot handle a high number of objects. The web viewer will 
struggle to show them and the AR view may crash. 

KeyShot is not a modeling application so it’s better to solve the issue before 
importing the model into KeyShot.
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13.812.517 polygons

148.255 polygons

Number of polygons
A high number of polygons can be a problem for most smartphones hardware. 
Also a higher polycount means a higher download time for the end user. 

Keyshot can simplify the model using different tools depending on the geometry 
type.

NURBS surfaces:

Tools > Re-Tessellate

Mesh surfaces:

Tools > Mesh Simplification

Tools > Edit Normals
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Normals orientation
Real-time engines shade a surface by looking at the surface normal direction. If 
the normal orientation is not consistent across surfaces, rendering errors may 
appear.

KeyShot has two tools that must be used in sequence to solve the issue:

Tools > Flip Normals

Tools > Edit Normals
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Surface separation
Separate the surfaces of a model to:

- save weight in export by hiding non-visible parts
- assign different materials to model components

Tools > Split Object Surfaces
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Materials compatibility
Some types of materials are not exportable from KeyShot: iridescents, volumetrics, and 
geometry-generating materials.

To maintain compatibility with Android and iOS AR engines, transparencies in My AR Studio are 
rendered without refraction.

https://manual.keyshot.com/manual/models-tab/export/export-formats/

https://www.myarstudio.cloud/learn/documentation/keyshot/keyshot-materials-in-ar/

https://manual.keyshot.com/manual/models-tab/export/export-formats/
https://www.myarstudio.cloud/learn/documentation/keyshot/keyshot-materials-in-ar/


Real-time rendering 
Exporting in GLB with KeyShot
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Rendering: Offline vs Real-time

OFFLINE RENDERING

KeyShot

Stills & Animations

Long rendering times

Advanced photorealism

REALTIME RENDERING

My AR Studio

Interactive content

Maximum 1/30 sec per rendering

Limited photorealism
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NURBS surface 960 triangles 224 triangles 48 triangles

Geometry in real-time

Real-time engines support only mesh 
geometries.

In most software, NURBS surfaces are 
automatically converted to mesh at the 
time of export.
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Real-time materials
Real-time models have a set of UV coordinates that allow 
textures to be used to define the characteristics of 
materials. 

The GLB format can use a maximum of 3 textures to define 
the characteristics of a material.

Color Texture 

- Color
- Transparency

ORM Texture 

- Occlusion
- Roughness
- Metallicity

Normal Texture 

- surface reliefs
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Android
Web

iOS

+

Workflow

KeyShot -> GLB -> MARS -> 

GLB per android e web + USDZ per iOS 

(+ QRcode + link + HTML embed?)

+
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Export to GLB
KeyShot will export only visible objects in the scene, hidden objects will be 
ignored.

File > Export > Export to GLB/GLTF
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The DPI parameter determines the size of the exported textures. The higher the DPI 
value, the more defined and heavy the textures will be.

The size of the model also affects the weight of the textures, so it is recommended 
to set DPI low for large models and vice versa.

Maintain a minimum of 16 samples so as not to detract from texture definition.

Click here or use the QR code on the side to see the sphere in My AR Studio.

Low DPI High DPI

Export to GLB

https://viewer.myarstudio.cloud/viewer_master/index.html?p=4e1b7c61-179c-50f1-9cd7-709ba9f076e3&b=d9525a15-3673-4474-9841-b2b3dcb7a78a&s=y
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Activating Ambient Occlusion Keyshot will generate a global shading texture for 
the object.

Increasing the samples parameter will increase the quality of the texture, 
however at the expense of export time.

Click here or use the QR code on the side to see the sphere in My AR Studio.

No AO AO low samples AO high samples

Export to GLB

https://viewer.myarstudio.cloud/viewer_master/index.html?p=4e1b7c61-179c-50f1-9cd7-709ba9f076e3&b=d9525a15-3673-4474-9841-b2b3dcb7a78a&s=y
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Export to GLB
Latest parameters:

Keep original UVs:
disable it if the model does not already have a set of UV maps

Compress using Draco:
keep always disabled, not used by My AR Studio for compatibility with iOS.

Enable Prefer Textures
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GLB file weight
Small GLB files are good for two reasons:

- The model download time for the end user is shorter
- The model can be displayed with a good framerate on older smartphones

Reference sizes:

- < 5MB ideal file size
- < 10MB good enough
- My AR Studio can display models up to 80MB
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Register
myarstudio.cloud

https://panel.myarstudio.cloud/register

