
My AR Studio
 

1



2

My AR Studio 

- My AR Studio: cos’è

- My AR Studio: come funziona

- Esercitazione

- Preparazione del modello in KeyShot

- Real-time rendering ed esportazione in GLB

Programma del corso
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My AR Studio è un sistema cloud che ti permette di caricare 
e distribuire i tuoi prodotti sul web e in AR. 

Cos’è
www.myarstudio.cloud 
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cliccare per vedere il video

https://docs.google.com/file/d/1FAa9hZgiYnOBi8kCpn0rCJeuBGp5tAWk/preview
https://www.youtube.com/watch?v=9m5XTOoNOwQ


youtube.com/@myarstudio instagram.com/my.ar.studio myarstudio.cloud/learn/it

info@myarstudio.cloudit.linkedin.com/showcase/myarstudio

Link utili
Accedi ai nostri contenuti

https://www.youtube.com/@myarstudio
http://instagram.com/my.ar.studio
https://www.myarstudio.cloud/learn/it/
mailto:myarstudio@puntoquindici.it
http://it.linkedin.com/showcase/myarstudio
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Come funziona
Trascina il modello del tuo prodotto in formato GLB all’interno 
dell’editor di My AR Studio.

Imposta i colori e l’illuminazione che lo valorizzano meglio. 

Pubblicalo in diverse configurazioni indipendenti o raggruppate 
in un unico selettore prodotto.
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Distribuzione
L’Universal Viewer di My AR 
Studio è lo strumento per 
distribuire i tuoi prodotti 
su ogni tipo di device.

Tramite la generazione 
automatica di link, QR Code 
e codice HTML, potrai 
coprire sia i browser 
desktop e mobile, sia la 
visualizzazione nativa 
in Realtà Aumentata di 
Apple iOS e Android.

Senza bisogno di app.
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Use Cases

myarstudio.cloud/it/esempi

Qualità e versatilità esemplificate.

Cliccare le immagini per aprire gli esempi

https://www.myarstudio.cloud/it/esempi/
https://viewer.myarstudio.cloud/viewer_master/index.html?p=b8402fe3-866e-5cd3-8211-c1fb782b4e5c&c=ea5db9f6-7ec7-53b3-98a7-6e275d9ca6b6&b=d9525a15-3673-4474-9841-b2b3dcb7a78a
https://viewer.myarstudio.cloud/viewer_master/index.html?p=61bc508d-fca6-5de8-af87-4ac04a217e8e&c=ecbe813f-1ef0-51ad-b40b-b398eb4bb26c&b=d9525a15-3673-4474-9841-b2b3dcb7a78a
https://viewer.myarstudio.cloud/viewer_master/index.html?p=f869f84a-b610-546e-b962-d03c1560691f&c=6e5dae4d-2b46-5797-b71f-71d68f436a23&b=d9525a15-3673-4474-9841-b2b3dcb7a78a
https://viewer.myarstudio.cloud/viewer_master/index.html?p=6313a734-8121-564f-85c5-127c17945ca7&c=6ba26219-e26e-5204-b36d-d034887e1995&b=d9525a15-3673-4474-9841-b2b3dcb7a78a
https://viewer.myarstudio.cloud/viewer_master/index.html?p=b515d3fe-ecc8-516b-b275-332b90242514&c=ae96f37b-4460-5947-92d8-4d6dc6fd7488&b=d9525a15-3673-4474-9841-b2b3dcb7a78a
https://viewer.myarstudio.cloud/viewer_master/index.html?p=1b519277-1515-5206-ac27-584872a25259&c=ba6205ae-0241-5b5a-8926-3993ba75b468&b=d9525a15-3673-4474-9841-b2b3dcb7a78a
https://viewer.myarstudio.cloud/viewer_master/index.html?p=b8402fe3-866e-5cd3-8211-c1fb782b4e5c&c=ea5db9f6-7ec7-53b3-98a7-6e275d9ca6b6&b=d9525a15-3673-4474-9841-b2b3dcb7a78a
https://viewer.myarstudio.cloud/viewer_master/index.html?p=61bc508d-fca6-5de8-af87-4ac04a217e8e&c=ecbe813f-1ef0-51ad-b40b-b398eb4bb26c&b=d9525a15-3673-4474-9841-b2b3dcb7a78a
https://viewer.myarstudio.cloud/viewer_master/index.html?p=6313a734-8121-564f-85c5-127c17945ca7&c=6ba26219-e26e-5204-b36d-d034887e1995&b=d9525a15-3673-4474-9841-b2b3dcb7a78a
https://viewer.myarstudio.cloud/viewer_master/index.html?p=f869f84a-b610-546e-b962-d03c1560691f&c=6e5dae4d-2b46-5797-b71f-71d68f436a23&b=d9525a15-3673-4474-9841-b2b3dcb7a78a
https://viewer.myarstudio.cloud/viewer_master/index.html?p=b515d3fe-ecc8-516b-b275-332b90242514&c=ae96f37b-4460-5947-92d8-4d6dc6fd7488&b=d9525a15-3673-4474-9841-b2b3dcb7a78a
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Documentazione
myarstudio.cloud/learn/it

youtube.com/@myarstudio

Documentazione estensiva con video tutorial:

- My AR Studio
- KeyShot
- Blender
- Substance Painter

https://www.myarstudio.cloud/learn/it/
https://www.youtube.com/@myarstudio
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Test your smartphone

Per lavorare con la realtà aumentata
e My AR Studio consigliamo:

Creazione

- Chrome web browser

Web viewer

- Qualunque web browser

Realtà Aumentata

- Smartphones recenti o abilitati (link)
- Chrome su Android
- Safari su iOS

Requisiti consigliati

https://www.myarstudio.cloud/learn/it/documentazione/distribuzione/realta-aumentata/


My AR Studio
Come funziona
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My AR Studio

Pagina Progetti

Elenco dei progetti, gestione account e link utili.

Pagina Configurazioni

Gestione delle configurazioni appartenenti a un 
singolo progetto.

Editor

Modifica di una singola configurazione.
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Pagina Progetti
Colonna sinistra

- Elenco progetti
- Profilo Utente
- Logout
- Guida contestuale
- Documentazione
- Bug report
- Chat

Riquadro dettagli del piano 
utilizzato

Area principale

- Pulsante aggiunta progetti +
- Ricerca progetti per nome
- Elenco progetti
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Editor
Dopo aver cliccato + di fianco all’intestazione Projects si apre la 
schermata dell’editor di un nuovo progetto.

- Centro area 3D
- In alto intestazione progetto
- Destra 5 tab con le proprietà del progetto

Trascinare un file GLB nella finestra per farlo caricare nell’editor.

Cliccare nell’intestazione per dare un nome significativo al 
progetto.
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Editor: Tab Export
Nella prima tab è possibile generare il poster, l’immagine usata 
come anteprima del vostro progetto:

- Attivare l’icona del poster
- Orientare il modello come si preferisce
- Cliccare il bottone generate poster
- Disattivare l’icona del poster

Impostare le export options per il progetto. Si tratta delle stesse 
opzioni disponibili nella pagina configurazioni.

Cliccare il tasto Save and Publish per pubblicare il progetto su 
My AR Studio.
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Editor: Tab Illuminazione
Qui è possibile impostare come sarà visualizzato il modello nell’ 
Universal Viewer. Specificando:

- L’HDR da utilizzare per l’illuminazione e la sua esposizione
- Lo sfondo
- La presenza di ombre e la loro intensità
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Editor: Tab Illuminazione
L’aspetto finale del modello dipenderà dalla modalità di 
visualizzazione utilizzata.

Nell’ Universal Viewer verranno utilizzate le impostazioni di 
illuminazione specificate nell’editor.

Nella Vista AR lo smartphone dell’utente farà un 
campionamento della luce ambientale. Utilizzerà questa al 
posto delle impostazioni di illuminazione, per meglio inserire il 
rendering nell’immagine catturata dalla fotocamera.
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Editor: Tab Materiali
Nella tab dei materiali si può modificare l’aspetto che avrà il 
modello sia nell Universal Viewer che in AR.

E’ possibile intervenire su: colore, lucentezza, metallicità, 
emissione e trasparenza.

Le possibilità effettive di modifica dipendono dalle specifiche di 
esportazione che sono state usate nel generare il file GLB.
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Editor: Tab Hotspot
Nella tab degli hotspot si possono aggiungere delle etichette 
visibili nel solo Universal Viewer.

Opzionalmente si può dare all’utente la scelta se visualizzare o 
meno gli hotspot.
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Editor: Tab Misure
Nella tab delle misure è possibile verificare le dimensioni reali 
del modello e scalarlo a piacere.
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Pagina Configurazioni 
Pubblicando un progetto dall’editor, oppure cliccando sull’icona del 
progetto dalla pagina di elenco progetti, si entra nell’editor delle 
configurazioni. 

Una configurazione è una particolare impostazione del vostro 
prodotto che può variare per: materiali, illuminazione, modello, etc.

A fianco della thumbnail di ogni configurazione ci sono 4 pulsanti:

- modificare la configurazione
- duplicare la configurazione
- rinominare la configurazione
- eliminare la configurazione

In basso a destra ci sono gli export della configurazione selezionata: 

- Universal Viewer link ed embed code
- QRcode link e download
- Poster Image link e download
- Modello USDZ link e download
- Modello GLB link e download
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Pagina Configurazioni
Aprire il pannello Preview & Options per abilitare le 
caratteristiche dell’ Universal Viewer per la configurazione 
selezionata.

- Visibilità del modello in AR
- Avvio automatico della visualizzazione 3D web
- Visibilità degli hotspot
- Visibilità delle dimensioni



23

Pagina Configurazioni
La tab del Selettore Prodotto permette di includere diverse 
configurazioni in un unica visualizzazione nell’ Universal Viewer.

L’utente potrà così scegliere la versione del prodotto che 
preferisce tramite un comodo menù a tendina.

Il Selettore Prodotto ha delle proprie impostazioni di preview & 
options specifiche,  distinte da quelle delle configurazioni 
singole.

In basso a destra si troveranno gli export del Selettore Prodotto, 
anch’essi distinti rispetto a quelli delle singole configurazioni.

- Universal Viewer link ed embed code
- QRcode download
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Eliminare una configurazione
Cliccando sul pulsante elimina configurazione o sul pulsante 
elimina progetto, a seconda della pagina in cui ci troviamo, si aprirà 
un dialogo di conferma.

My AR Studio non effettua subito l’eliminazione perchè i link, il 
codice embed e il QR code associati alla configurazione 
smetteranno di funzionare. Quindi agli utenti che cliccano su un link 
già pubblicato verrà restituita una pagina “progetto non trovato”.

I link eliminati non sono recuperabili. Se carichiamo lo stesso 
oggetto in un nuovo progetto o in nuova configurazione verranno 
generati dei nuovi link diversi dai precedenti.

Si ricorda invece che le configurazioni sono continuamente 
aggiornabili. Se per esempio è uscita una nuova versione del nostro 
prodotto, possiamo modificare la configurazione già pubblicata 
caricando il nuovo modello. I vecchi link continueranno a funzionare 
mostrando però la versione aggiornata.



Esercitazione
Caricare e pubblicare un modello

25



Preparazione del modello
Ottimizzazione e risoluzione problemi con KeyShot
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Panoramica
Lo scopo della preparazione del modello all’esportazione è di trovare il miglior 
compromesso possibile tra peso e qualità. Garantendo minori tempi di 
caricamento per l’utente e una vista AR performante su ogni modello di 
smartphone abilitato.

Checklist di esportazione

- Riduzione del numero di oggetti
- Riduzione del numero di poligoni
- Orientamento delle normali di superficie
- Separazione delle superfici per materiale
- Compatibilità dei materiali
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Numero di oggetti

15 objects 7425 objects

I motori real-time non possono gestire un numero elevato di oggetti. Il web viewer 
farà fatica a mostrarli in maniera fluida e la vista AR potrebbe bloccarsi.

KeyShot non è un programma di modellazione, quindi è bene risolvere il 
problema prima di importare il modello in KeyShot.
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Numero di poligoni
Un elevato numero di poligoni può essere un problema per l’hardware di molti 
smartphone. Inoltre più la conta dei poligoni è alta più si allungheranno i tempi di 
download per l’utente finale.

KeyShot può semplificare il modello usando tool differenti a seconda del tipo di 
geometria di cui è composto.

Superfici NURBS:

Tools > Re-Tessellate

Superfici Mesh:

Tools > Mesh Simplification

Tools > Edit Normals

13.812.517 polygons

148.255 polygons
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Orientamento delle normali
I motori real-time calcolano l’ombreggiatura delle superfici guardando alla 
direzione delle loro normali. Se l’orientamento delle normali non è coerente tra le 
varie superfici, si potrebbero verificare degli errori di rendering.

In KeyShot ci sono due tool che vanno usati in sequenza per risolvere il problema:

Tools > Flip Normals

Tools > Edit Normals
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Separazione delle superfici
Separare le superfici di un modello per:

- risparmiare peso in esportazione nascondendo le parti non visibili
- assegnare materiali diversi alle componenti del modello

Tools > Split Object Surfaces
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Compatibilità dei materiali
Alcune tipologie di materiali non sono esportabili da KeyShot: 
gli iridescenti, i volumetrici e quelli che generano geometria.

Per mantenere la compatibilità con i motori AR di Android e iOS, 
le trasparenze in My AR Studio vengono renderizzate senza rifrazione.

https://manual.keyshot.com/manual/models-tab/export/export-formats/

https://www.myarstudio.cloud/learn/it/documentazione/keyshot/materiali-keyshot-in-ar/

https://manual.keyshot.com/manual/models-tab/export/export-formats/
https://www.myarstudio.cloud/learn/it/documentazione/keyshot/materiali-keyshot-in-ar/


Real-time rendering 
Esportazione in GLB con KeyShot
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Rendering: Offline vs Real-time

OFFLINE RENDERING

KeyShot

Stills & Animazioni

Lunghi tempi di rendering

Fotorealismo avanzato

REALTIME RENDERING

My AR Studio

Contenuti interattivi

Massimo 1/30 sec per rendering

Fotorealismo limitato
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Geometria in real-time

I motori real-time supportano 
solo geometrie mesh.

Nella maggior parte dei software, 
le superfici NURBS vengono 
automaticamente convertite in 
mesh al momento 
dell’esportazione.

NURBS surface 960 triangoli 224 triangoli 48 triangoli
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Materiali in real-time
I modelli real-time hanno un set di coordinate UV 
che permettono di usare delle texture per definire 
le caratteristiche dei materiali. 

Il formato GLB prevede l’utilizzo di massimo 3 texture per la 
definizione delle caratteristiche di un materiale.

Texture colore

- Colore
- Trasparenza

Texture ORM

- Occlusione
- Ruvidità
- Metallicità

Texture delle normali

- rilievi di superficie 
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per Android
e Web

per iOS

+

Workflow

KeyShot -> GLB -> MARS -> 

GLB per android e web + USDZ per iOS 

(+ QRcode + link + HTML embed?)

+
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Esportare in GLB
KeyShot esporterà solo gli oggetti visibili in scena, gli oggetti nascosti verranno 
ignorati.

File > Export > Export to GLB/GLTF
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Esportare in GLB
Il parametro DPI determina la dimensione delle texture esportate. 
Più alto è il valore di DPI più definite e pesanti saranno le texture.

Anche le dimensioni del modello influenzano il peso delle texture, 
quindi si consiglia di impostare DPI bassi per modelli grandi e viceversa.

Mantenere un minimo di 16 samples per non togliere definizione alle texture.

Cliccate qui o inquadrate il QR code a lato per vedere la sfera in My AR Studio.

Low DPI High DPI

https://viewer.myarstudio.cloud/viewer_master/index.html?p=4e1b7c61-179c-50f1-9cd7-709ba9f076e3&b=d9525a15-3673-4474-9841-b2b3dcb7a78a&s=y
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Esportare in GLB
Attivando Ambient Occlusion Keyshot genererà una texture di ombreggiatura 
globale dell’oggetto.

Aumentando il parametro samples si aumenterà la qualità della texture, però 
a  scapito dei tempi di esportazione.

Cliccate qui o inquadrate il QR code a lato per vedere la sfera in My AR Studio.

No AO AO low samples AO high samples

https://viewer.myarstudio.cloud/viewer_master/index.html?p=4e1b7c61-179c-50f1-9cd7-709ba9f076e3&b=d9525a15-3673-4474-9841-b2b3dcb7a78a&s=y
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Esportare in GLB
Ultimi parametri:

Keep original UVs:
abilitare solo se il modello possiede già un set di mappe UV.

Compress using Draco:
mantenere sempre disabilitato, non è utilizzato da My AR Studio per compatibilità 
con iOS.

Abilitare Prefer Textures
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Peso dei file GLB
E’ preferibile esportare file GLB di piccole dimensioni per due motivi:

- I tempi di download per l’utente finale sono inferiori
- Il modello può essere visualizzato con un buon framerate anche su 

smartphone più vecchi

Dimensioni di riferimento:

- 3-5 MB dimensione file ideale
- < 10 MB abbastanza buona
- My AR Studio può visualizzare modelli fino a 80 MB
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Registrati
myarstudio.cloud

http://panel.myarstudio.cloud/register

